WordPressのグーテンベルクの再利用ブロックが、ブロック追加でたまに表示できなくなった話し

現在、さくらインターネットで本ブログを運用していますが、いろいろ障害が出ています。

障害というのは、必ず発生するのであれば原因を特定しようがあるのですが、たまに発生するというのは意外と厄介です。出るときと出ないときがあって、特にたまたま出るというのは何ともしがたいのです。

たまにInternal Server Errorが出ると、ずっと言ってきて、ああでもないこうでもないと対策を取ってきましたが、なかなか解決はしません。今度は、Gurtengergの編集画面で、再利用ブロックが表示できなくなっていました。

正常ならば、左上のブロック追加の+アイコンを押すと、再利用可能というタブが出てくるのですが、いくら待っても出てこないことがあります。

正常な状態。だけど、Wordpressのアイコンが表示していないのもおかしい

何回かブラウザで更新をしてあげると、再利用ブロックのタブが出てくれることがあります。何回かというのも定かではありません。これは気まぐれです。

もし、既に再利用ブロックが記事内に挿入されているのであれば、うまく再利用ブロックのプレビューが表示できていません。

こんな感じで再利用ブロックが真っ白なままです。こちらも、何回かブラウザの更新をしてあげると、まともにプレビューをしてくれることがあるので更新ボタンを繰り返し押します。

おそらくサーバーのメモリが足りないとかの原因だとは思いますが、さくらインターネットのサーバーが悪いのか、こちらのWordpressのサイトが悪いのか、はたまたこちらのネットワークが悪いのか、今のところ断定ができません。断定できないとなると、さくらインターネットのサポートに連絡して手間をかけることもできません。

とりあえず、しつこくブラウザの更新をすればサーバーが機嫌が良ければ治る、という曖昧な回避策があるので何とかやっているのですが、さてこれからどうしましょうか???

なんやかんやでWordPressのサイト構築で躓くのは、PHPのプログラミングなのでした。

追記

ChromeのConsoleを見ると、エラー出ています。この辺りが怪しいかもしれません。

エラーの内容からWordpressのサイトにログインしているけど、ログインできていないようなエラーのような気がします。ログインできていないから、再利用ブロックの取得ができないということかもしれません。

いずれにしても、今のところ解決策はありません。

追記2

今インストールしているWordpressのプラグインを無効にしたり有効にしたりしましたが解決せず、もしかしたらということで、Gurtengergのプラグインをインストールしてみました。Gurtengergプラグインをアンインストールしたのは、再利用ブロックが10個以上表示できなかったのでアンインストールしていました。

Gurtengergのプラグインをインストールしたところ、再利用ブロックが表示できるようになりました。だけど、必ず再利用ブロックが表示できるとは限らないというものも痛いところです。まだまだ、Gurtengergは不安定なところが残っているのでしょうか?

しかも、再利用ブロックは正常に10個以上表示できていますGurtengergのプラグインをインストールしていなくても、今までどうしてGurtengergが使えていたのは、今となってはわかりません。

何だかWordpressというCMSは、よくわからなくなりました。

追記3(2021年2月3日)

最近になって、また再利用ブロックが表示しなくなった。今度は確実に再利用ブロックが表示できない。

この記事を書いた間にGurtengergのバージョンが何度かアップされたので、それが原因なのか、それともさくらインターネットのサーバーが原因なのか?

さくらインターネットのコンソールからエラーログを見ると、

End of script output before headers: index.

というエラーが出ていた。

End of script output before headers さくら WordPress

でGoogleさんに聞いてみると、ファイルのパーミションを確認しろと出てくるが、確認しても問題ない。

今のところ原因不明である。おそらくサーバーだな。